Debian building image failure

I’ve tried building a new debian image following GitHub - mixtile-rockchip/build and get the following error:

P: Running debootstrap second stage under QEMU
chroot: failed to run command '/usr/bin/env': No such file or directory
E: An unexpected failure occurred, exiting...
tar -jcf linaro-bullseye-alip-`date +%Y%m%d`-1.config.tar.bz2 auto/ config/ configure;
sudo mv chroot.files linaro-bullseye-alip-`date +%Y%m%d`-1.contents;
mv: cannot stat 'chroot.files': No such file or directory
make: *** [Makefile:24: all] Error 1
ERROR: Running /build/blade3/device/rockchip/common/scripts/ - build_debian failed!

Please advise how to get past this error.

Hello, we have a guide on compiling Debian images for Mixtile Core 3588E on our official website. Please follow this guide.

Compile Debian Image from Source Code | Mixtile

Hi Kevin. I actually ran through the github workflow that that document basically repeats and get the same result. The only deviation is ubuntu-latest is actually the Microsoft github VM github workflow uses. The last time this workflow successfully ran was 3 months ago and Microsoft has released a new ubuntu-latest since then. I wonder if someone reran the build repo workflow if it would still pass.

We have tried it on both the local machine and Github Actions, and it compiles fine. Github Actions Yesterday’s compilation log is here.

Build with Mixtile Core3588E Debian

The workflows file for Github Actions is here

Github Actions workflows file for Mixtile Core3588E Debian

You can view the compilation log of Actions and download Artifacts to flash Mixtile Core3588E.

Thank you for re-running that to verify. I followed the exact commands the pipeline ran and it worked and I was able to successfully upload the firmware! I might have missed installing qemu-user-static.

The only thing missing is the special pci0 networking driver. I’ll try to find it but any hints would be helpful. Thank you.

Hi, by “the special pci0 networking driver” do you mean the M.2 socket (E key) used on the Mixtile Core 3588E?

If so, what chip model do you use? You may need to enable the driver for this chip in the Linux kernel configuration.

The pci0 backplane IP network device for the clusterbox.

There may be some information errors, because this question is classified on the Mixtile Core 3588E product. I thought it was the Mixtile Core 3588E PCIe driver that could not recognize the network card. If you want to solve the clusterbox pcie driver problem, you can ask here.

Looks like this is provided by miop-control Install Drivers for Blade 3 Boards | Mixtile.

According to Blade 3 Driver (miop-control-arm64.deb) this is not open source yet. When I try to install the miop-control-arm64.deb, it was built with 5.10.66 and the current kernel version that builds from the build pipeline is 5.10.160.

Looks like I have to figure out how to downgrade the kernel back to 5.10.66 and then rebuild the image.