Upgrading Debian 11

Hello! I received some Blade 3 boards and am excited to begin using them!

I find that in the current image (20230214) for the Blade 3, a huge list of apt packages are held. Upon unholding and upgrading, the system will fail to boot into a graphical desktop again. Ideal state is to not require holding any packages to maintain a working system. Will this be resolved in the upcoming firmware version? If not, can this be listed in the “known issues” section and tracked for resolution?

Also, what is the intended process to upgrade between firmware versions as they’re released? Will it require a reflash?

Thanks in advance!

1 Like

Hello Rob, thanks for the feedback about Blade 3 boards. I’m Bobby from Mixtile and glad to help you about this. We tried unholding and upgrading, it will boot into a graphical desktop normally. Below is our steps. Using command sudo apt-mark unhold $(apt-mark showhold) to unhold all held apt packages, then using command sudo apt update && sudo apt upgrade to upgrade apt packages. Then reboot and it could boot into graphical desktop, system version is 20230214. Could you kindly advise if there are some other different steps in your Blade 3 board?

Yes, it required a reflash to upgrade different firmware versions. The instruction of updating firmware is in Docs of Blade3 here: https://www.mixtile.com/docs/Mixtile-Blade-3-Docs/Getting-started/update-firmware/loader-mode/

Thanks for the quick response!

I reflashed the 20230214 image and tried again. It seems the difference between my steps and yours were that I ran sudo apt full-upgrade which caused several X.org-related packages to be upgraded as well. Upon running only sudo apt upgrade, the X.org packages are held back (for reasons other than marked) and the system will continue to boot to the graphical desktop. I’ll note to run only sudo apt upgrade on the Blade 3 going forward.

To note, flashing the Blade 3 using Loader mode failed immediately after the image had been uploaded. Booting to MaskROM mode allowed successful reflashing of the Blade 3. Also, a 15W PD charger was insufficient for booting after reflashing: the Blade 3 would boot loop until I provided a stronger PD charger. With the stronger charger, the board was able to run the Android recovery and recreate /userdata. The 15W PD charger seems to work fine for regular boot after reflash and recovery, but I haven’t yet attempted to stress the board yet with the 15W PD charger.

Regarding the Loader mode, could you kindly share more information (like some screenshots or log) about the fail? It will be very helpful for making this product more stable. In our testing, Loader mode works well and we don’t have issue by now.
Regarding the power supply issue after reflashing in MaskROM mode, we also noticed that and listed it in the known issues in our website. We are working to solve this issue, and we think the reason is not power insufficient. In generally the PD power adapter will wait for a certain time to receive the request from Blade 3 board, some adapter wait longer time and some wait shorter time. But in recovery mode Blade 3 need more time to load the PD driver and this may miss the waiting time of some PD power adapter. We plan to solve this issue in the next version firmware and will send the email notice to all user when releasing the firmware. Sorry for the inconvenient right now, if you have more questions, feel free to contact us.

Yes, I found the log from attempting with Loader mode. It is as follows:

10:02:36        Upgrade Tool v1.65

10:02:36        Current process in /home/robert/Downloads/Linux_Upgrade_Tool/Linux_Upgrade_Tool_v1.65
10:02:36        Not found config.ini,in the /root/.config/upgrade_tool/config.ini
10:02:36        Command Line: ./upgrade_tool uf /home/robert/Downloads/image-release-blade3-debian11-20230214.img
10:02:36        Current Device Location ID:13
10:02:36        Test Device Start
10:02:36        Test Device Success
10:02:36        Check Chip Start
10:02:36        Check Chip Success
10:02:36        Get FlashInfo Start
10:02:36        INFO:FlashInfo: 0 60 8F E 0 4 4 0 28 0 1
10:02:36        Get FlashInfo Success
10:02:36         Prepare IDB Start
10:02:36        INFO:CS(1)              (119276MB)              (SAMSUNG)
10:02:36        Prepare IDB Success
10:02:36        Download IDB Start
10:02:36        INFO:DownloadIDBlock-->New IDB
10:02:36        Download IDB Success
10:02:36        Download Firmware Start
10:02:36        INFO:FlashInfo: 0 60 8F E 0 4 4 0 28 0 1
10:02:36        INFO:Start download image,total=3452323328,band=64,DirectLBA=1,First4Access=1,Gpt=1
10:02:36        INFO:Start to download uboot,offset=0x4000,size=4194304
10:02:36        INFO:Start to download misc,offset=0x6000,size=49152
10:02:36        INFO:Start to download boot,offset=0x8000,size=32076288
10:02:37        INFO:Start to download recovery,offset=0x28000,size=121425408
10:02:40        INFO:Start to download rootfs,offset=0xb8000,size=3272605696
10:04:08        INFO:Start to download oem,offset=0x1cb8000,size=17457152
10:04:09        INFO:Start to download userdata,offset=0x1cf8000,size=4481024
10:04:09        ERROR:RKA_Gpt_Download-->compare gpt backup failed
10:04:09        ERROR:DownloadImage-->RKA_Gpt_Check failed
10:04:09        Download Firmware Fail
10:04:09        Command mode out

For comparison, this next log is the successful flash using MaskROM mode on the same Blade 3 with the same host, cable, PD power adapter, image, etc:

10:07:45        Upgrade Tool v1.65

10:07:45        Current process in /home/robert/Downloads/Linux_Upgrade_Tool/Linux_Upgrade_Tool_v1.65
10:07:45        Not found config.ini,in the /root/.config/upgrade_tool/config.ini
10:07:45        Command Line: ./upgrade_tool uf /home/robert/Downloads/image-release-blade3-debian11-20230214.img
10:07:45        Current Device Location ID:13
10:07:45        Download Boot Start
10:07:46        Download Boot Success
10:07:46        Wait For Maskrom Start
10:07:48        Wait For Maskrom Success
10:07:48        Error:libusb_release_interface failed,err=-4
10:07:48        Test Device Start
10:07:48        Test Device Success
10:07:48        Check Chip Start
10:07:48        Check Chip Success
10:07:48        Get FlashInfo Start
10:07:48        INFO:FlashInfo: 0 60 8F E 0 4 4 0 28 0 1
10:07:48        Get FlashInfo Success
10:07:48         Prepare IDB Start
10:07:48        INFO:CS(1)              (119276MB)              (SAMSUNG)
10:07:48        Prepare IDB Success
10:07:48        Download IDB Start
10:07:48        INFO:DownloadIDBlock-->New IDB
10:07:48        Download IDB Success
10:07:48        Download Firmware Start
10:07:48        INFO:FlashInfo: 0 60 8F E 0 4 4 0 28 0 1
10:07:48        INFO:Start download image,total=3452323328,band=64,DirectLBA=1,First4Access=1,Gpt=1
10:07:48        INFO:Start to download uboot,offset=0x4000,size=4194304
10:07:48        INFO:Start to download misc,offset=0x6000,size=49152
10:07:48        INFO:Start to download boot,offset=0x8000,size=32076288
10:07:49        INFO:Start to download recovery,offset=0x28000,size=121425408
10:07:52        INFO:Start to download rootfs,offset=0xb8000,size=3272605696
10:09:22        INFO:Start to download oem,offset=0x1cb8000,size=17457152
10:09:23        INFO:Start to download userdata,offset=0x1cf8000,size=4481024
10:09:23        INFO:Start to check uboot,offset=0x4000,size=4194304
10:09:23        INFO:Start to check misc,offset=0x6000,size=49152
10:09:23        INFO:Start to check boot,offset=0x8000,size=32076288
10:09:24        INFO:Start to check recovery,offset=0x28000,size=121425408
10:09:27        INFO:Start to check rootfs,offset=0xb8000,size=3272605696
10:10:54        INFO:Start to check oem,offset=0x1cb8000,size=17457152
10:10:55        INFO:Start to check userdata,offset=0x1cf8000,size=4481024
10:10:55        Download Firmware Success
10:10:55        Reset Device Start
10:10:57        Reset Device Success
10:10:57        Error:libusb_release_interface failed,err=-4
10:10:57        Command mode out

If there’s any additional information I can collect to help troubleshoot, please let me know and I’d be happy to find it.

Also, to show a screenshot of the console:

I just performed a flash on a different Blade 3 with this same result. Now that I’m using the more powerful PD adapter, I notice now that the flash actually is successful despite the red Download Firmware Fail! message. Like the logs state, no checking was performed to validate the successful flash.