How to get up and running witht he Cluster Box

Hi there,

I would like to get started with the cluster box, but I am getting nowhere… With the old and new control board I am unable to get any nodes visible. I tried flashing the Mixtile 3 boards with new firmware and OS, but I seemed to fail in that process too. For flashing, I used the images as denoted here: Firmware Images | Mixtile and I used the process that was denoted here: Upgrade Firmware Using Raw Image | Mixtile and I, for some reason, cannot make it complete successfully. I have been playing around with the SPST switch, but when I set it to off-off-off-on (only ON for position 4) then the flashing tool doesn’t recognize the board. I have tried this for all 4 boards on both Windows and Ubuntu…

Note: The boards do not register in OpenWRT, and I cannot find any DHCP leases for the nodes.

I am full aware that this is not a helpful ask yet. What, I would like to have clear instructions on how to get this operational. Considering that I have the issues on all 4 boards, I feel certain that the problem lies with me. For this reason, my ask for help is all the more sincere.

Thank you for your time and patience

Hello Pieter, please follow the steps below to identify the issues.

  1. Check if 4 Blade3 boards can boot up normally, then check if you could use the ADB to login to the boards. If so, you don’t need to use SPST switch, you could use loader mode to flash the new firmware as per this instruction
  2. Check if the system of 4 Blade3 boards is Debian 11. There are some issues when using the Ubuntu system.
  3. Download the boot.img to the Blade3 boards and install the PCIe driver for them as per this instruction

If there are any issues thereafter, please send an email to our support team, and we will be glad to assist you further.

1 Like

Hey there,


So I have made some progress with flashing the devices and setting everything up. As discussed, I followed the manual. I have tried connecting through ADB, but that didnt work. So instead I enabled the MaskROM mode by setting the SPST switch to 0001. I was able to flash the devices with windows, after rereading the manual and this time understanding that I need not just the tool, but also the drivers. Flashing the ROM, I tried to copy over the boot partition and then install the network driver.

At my first go of installing the drivers, I got an error when running dpkg. This error seems to resolve itself when restarting the devices, and then rerunning the installation with dpkg. I share my first run below, that contains the error:

adb shell

root@blade3:/# lsblk
mmcblk1      179:0    0 116.5G  0 disk
├─mmcblk1p1  179:1    0     4M  0 part
├─mmcblk1p2  179:2    0     4M  0 part
├─mmcblk1p3  179:3    0    64M  0 part
├─mmcblk1p4  179:4    0   256M  0 part
├─mmcblk1p5  179:5    0    32M  0 part
├─mmcblk1p6  179:6    0    14G  0 part /
├─mmcblk1p7  179:7    0   128M  0 part /oem
└─mmcblk1p8  179:8    0   102G  0 part /userdata
mmcblk1boot0 179:32   0     4M  1 disk
mmcblk1boot1 179:64   0     4M  1 disk
nvme0n1      259:0    0   1.8T  0 disk

root@blade3:/# ls
bin   home	  oem		 run		   srv	   userdata
boot  lib	  opt		 sbin		   sys	   usr
data  lost+found  proc		 sdcard		   system  var
dev   media	  rockchip-test  sha256sum.README  tmp	   vendor
etc   mnt	  root		 sha256sum.txt	   udisk
root@blade3:/# cd home/mixtile/
root@blade3:/home/mixtile# ls
Desktop  boot.img  miop-control-arm64.deb
root@blade3:/home/mixtile# sudo dd if=boot.img of=/dev/mmcblk1p3 conv=sync
62649+0 records in
62649+0 records out
32076288 bytes (32 MB, 31 MiB) copied, 1.63353 s, 19.6 MB/s

root@blade3:/home/mixtile# sudo dpkg -i miop-control-arm64.deb
Selecting previously unselected package miop-control.
(Reading database ... 67296 files and directories currently installed.)
Preparing to unpack miop-control-arm64.deb ...
Unpacking miop-control (1.0.0) ...
Setting up miop-control (1.0.0) ...
/lib/miop /
insmod: ERROR: could not insert module miop-reg.ko: Unknown symbol in module
insmod: ERROR: could not insert module pcie-ep-rk35.ko: Unknown symbol in module
insmod: ERROR: could not insert module miop-ep-net.ko: Unknown symbol in module
insmod: ERROR: could not insert module miop-ep.ko: Unknown symbol in module


I can now list the nodes through ssh:

bash-5.2$ nodectl list
If no device is found, run the rescan command and then the list command to view the device.
03:00.0 Network controller: Mixtile Limited Blade 3 (rev 01)
04:00.0 Network controller: Mixtile Limited Blade 3 (rev 01)
05:00.0 Network controller: Mixtile Limited Blade 3 (rev 01)
06:00.0 Network controller: Mixtile Limited Blade 3 (rev 01)

And I can see the DHCP leases in the UI:

Note that I am still missing a node, which is node 1. I was not able to reconnect after reboot, to reinstall the networking drivers with dpkg because the ADB connection seems to not work for this specific node.

Issue with ABD connection, but only for Node1

I was able to connect, flash and install all the nodes, except for node 1. I sometimes have a connection with node 1, but seem to be kicked out when I am in the shell. I don’t understand why yet. I will test whether this has something to with the box, by switching the position of the node itself, and I will retry flashing and installing everything. Maybe there was an error somewhere in the process.

Do you have tips for the debug? How can we rule our hardware issues?

Thanks again for the help!

LOL, so getting out the modules and reseating worked!

Do you have any advice for setting up the routing part? I intend to use it as a Kubernetes cluster. My last question would be, how open is the current development? I found the RK3588 Ubuntu distro that you guys are collaborating on, which is amazing. As you guys pointed out already, the MIOP driver is not open sourced yet and Ubuntu doesn’t seem to play ball with MIOP either. I understand that these bugs are large, but would like to know what your plan is and whether there is any light on future development of this platform (cluster-box).

Thanks for your time!

1 Like