Tutorial: How to use the hub with openHAB 2.3


#42

Hello, I have tried to install openHAB on the Mixtile hub twice with the same result. See picture below.

Also, should Step 10 a. be cd /home/data/openhab/userdata
instead of cd /openhab/userdata?

Result of start mhub.service

Any suggestion?
Thanks,
Donut


#43

Are young from EU? Just to know…
I Am in your exact , equal, condition. I tried several time, with @Bac (team member) help but I cannot run OpenHab on it .
Step 10 is /home/user/OpenHab/userdata, not /home/data…


#44

Hi @donut and @Gabriele_Castiglioni

I recorded a video for this tutorial. Tomorrow I’ll upload it online.

Best

Bac

Mixtile Team


#45

@Gabriele_Castiglioni
Hello, yep I’m in the EU. I double checked the permissions and the mhub.service file.

@Bac
Thanks, I’ll give it a go.

I hope we can get this sorted.


#46

@donut @Gabriele_Castiglioni

The video is here https://youtu.be/CSUjjQaGTwk

I recorded the video once, so it may be a bit slow.


#47

@Bac
Followed the video step by step, it didn’t work =[

Same result as before


#48

@Gabriele_Castiglioni

Any luck with you?

Bac


#49

No. Exactly the same as screen above by @donut
I get always EXEC/203 that AFAIK means “file not found”
But what the hell start.sh won’t find, I dunno.


#50

Was already some time that I visited the community, the Mixtile was collecting dust. This article is just what I was hoping for when I joined the crowdfunding.

So, basically it worked, the only thing different on my installation was the location, instead of /usr/share etc it was on /opt/mhub
Took some time but the paper ui and all the other ui’s are running.
My current home automation is Domoticz with its flexible scripting hence the need for openhab2. Not knowing anything of openhab2 :slight_smile: started with creating a rule (Mixtile status led on/off) and a virtual switch.
Then the sitemap with that switch and yes I can switch on/off the status led yeah… some xiaomi sensors are also reporting on the sitemap so it is definitely starting to look something.

Great, thanks guys

On more thing, a while back I asked for the nano editor. That link is no longer valid and with a system update the nano has disappeared. Can some team member provide the nano please, I really hate vi

Cheers


#51

Hi @Gabriele_Castiglioni and @donut

I’ll try to investigate further on the problem and let you two know if I found a solution.

Hi @joebar

Thanks for using our hub again and noted about the nano editor.

Best,

Bac

Mixtile Team


#52

Thanks very much @Bac


#53

Hi

Is Mixtile compatible with the 2.4 versión de Openhub?

Thanks


#54

Hi @TiNePaS

I’m not sure. I haven’t updated this tutorial with the latest openHAB version. Also if you’re using the latest firmware of our hub, a couple system files have been moved. mhub is now located in the /opt/ directory instead of /usr/share.

You can try downloading 2.4.0 and try it yourself. Let us know if you were able to do it.

Bac

Mixtile Team


#55

Sorry, but I prefer that adults will do it :kissing_heart:

I will wait your update tutorial.


#57

Hi,


Can someone help me?


#58

Hi,

This tutorial hasn’t been updated in a while. Some of the system files location has been changed and there is a newer version of openHAB which I haven’t tested yet. Keep a lookout in the next two weeks for an update

Bac

Mixtile Team


#59

Hi,

I have followed the tutorial, but cannot get openhab to load. When I start the service and check the journal it seems to get stuck here:

2019-02-24 09:13:32.655 [SEVERE ] [com.mixtile.hub.io.openhabcloud.internal.CloudService getLanguage] - language:en_US

Any ideas?

Thanks!


#60

That line shouldn’t affect openHAB to load. It appears that not all our users were able to get openHAB to work.


#61

I would highly appreciate an updated tutorial for openhab 2.4 and the latest Mixtile firmware :slight_smile:


#62

Hi Dominik,

I’ve installed and tested openHAB 2.4, but it appears to be incompatible with our hub right now.

Bac

Mixtile Team