Tutorial: How to use the hub with openHAB 2.3


#21

The easiest way is to factory reset. If you don’t want to reset your hub then you can delete/change the mhub folder, rename the mhub-back folder back to mhub, and change the mhub.service back to what it was originally.


#22

I see you don’t want to give me detailed instructions. I’m user, not programmist. I want homeKit working because your team told me that it could be done before I received mixtile hub. So I bought it because of this! Now I received it with something broken inside. I patiently wait another one hub, that was sent for me for 3 times (2 times were unsuccessfull!!). so why everything that I ask, I need to ask 3 or more times and waiting for 2-3 months?

If you are still using ESH, just put the HomeKit jar file in

/usr/share/mhub/runtime/concierge/system/org.eclipse.smarthome

add HomeKit addon line to

/usr/share/mhub/runtime/concierge/smarthome.xargs

then restart your mhub service.

what is HomeKit addon line? how can I add it?
what is needed to do after restarting hub?
is it true resourse ?

Please, tell me If you are not able to help. I’ll throw away this hub and forget about it and your project.


#23

Hi,

This tutorial is written for developers that want to further develop the hub with openHAB by themselves. There are hundreds of bindings/services in openHAB and it will be hard for us to develop every single one of them to work perfectly with our hub. Hence why we have this tutorial for our users.

We tried our hardest to get you a new hub. Although you live in a different country than the one in our records, we still agreed to exchange the hub for you. But it was out of our power that your country’s strict custom laws stopped the package.

I’m sorry for the confusion. All the way down the smarthome.xargs file, you can see a list of bindings. Add the homekit jar line similar to picture below.

image


#24

Developers can do everything in openhab without your hub, that means ready to work solution. Your audience consist of end-users. So many functions that were declared on indiegogo don’t work now (hdmi support, for example), or work with bugs (journal, connection, app functionality). We, end-users, waiting patiently for updates. So, please, help us with our problems.
Tell me how I could see that file? With what command? You made picture with terminal window. Was it difficult to show command on it?! It is everything that l need - instruction.


#25

Hi,

Sry guys, pls use a new Topic for HomeKit question.
Will to much different informations inside here.

@Bac
can you give me bit support for this the ZigBee and Z Wave get work in openHAB.
I tried also to ask the openHAB community, but not easy without more informations.
thanks a lot for your support :slight_smile:


#26

Hi @egoist

Technically true. Developers could use openhab without our hub, but they still need to get physical modules to connect to Z-wave and zigbee devices. Our hub provides them with the main 4 radios, storage, processor, and much more. Our team is constantly working to make our hub and apps better every day. Each month we publish 1-2 updates to the hub, 1 android, and 1 apple. My apologies for the unclear instruction. You were able to set up openhab and seem knowledgeable with smart products, so I automatically assume you were an expert developer.

Hi @Tobias

Good to hear from you again! I like that you are spending time to explore openhab by yourself. I’m expecting a complete futuristic smart home from you. To answer your question, our hub already support many zigbee and z-wave devices.

On openhab you can use the mixtile binding to find zigbee, z-wave, bluetooth, and WiFi devices all together. All the compatible devices in ourlist will work fine, because our development team already tested them. You may find other zigbee/z-wave devices, but they may not work well with our hub yet.

But if you want to use the zigbee or z-wave bindings to find devices, then you will need to manually port those bindings to the hub’s zigbee/z-wave modules first. The serials port are below:

image

Please note that not all zigbee/zwave devices will work with our hub. It depends on what their versions are. The Zigbee module in our hub is TI CC2538. The Z-Wave one is SigmaDesigns ZM5304. The Z-Wave module is further divided into 3 regions. For example, you cannot connect your EU z-wave product to your U.S. hub. The US and EU use different Z-wave frequencies.

Click here to read more about the Z-wave and Zigbee bindings on openHAB

If you click on the links above, you can see all the bindings on the left. Some bindings work right away without any configurations needed. For example, I can use the YahooWeather binding to view the weather of my town on my mixtile app. Then I set a routine to send me a notification when the weather gets too cold. (You just need to google what the WOEID is for your area. )


#27

Hi to all.
I-m asking for your help about this…
I did all the 20 steps of this thraed to have OpenHAB on a rooted MixTile hub ZB/ZWave , but every time I end up with this journal:

– Logs begin at Sat 2018-11-03 21:33:47 UTC. –
Nov 09 22:03:20 MixtileHub systemd[1]: mhub.service: Main process exited, code=exited, status=203/EXEC
Nov 09 22:03:20 MixtileHub systemd[1]: mhub.service: Control process exited, code=exited status=1
Nov 09 22:03:20 MixtileHub systemd[1]: mhub.service: Unit entered failed state.
Nov 09 22:03:20 MixtileHub systemd[1]: mhub.service: Failed with result ‘exit-code’.
Nov 09 22:03:21 MixtileHub systemd[1]: mhub.service: Service hold-off time over, scheduling restart.
Nov 09 22:03:21 MixtileHub systemd[1]: Stopped The openHAB 2 Home Automation Bus Solution.
Nov 09 22:03:21 MixtileHub systemd[1]: mhub.service: Start request repeated too quickly.
Nov 09 22:03:21 MixtileHub systemd[1]: Failed to start The openHAB 2 Home Automation Bus Solution.
Nov 09 22:03:21 MixtileHub systemd[1]: mhub.service: Unit entered failed state.
Nov 09 22:03:21 MixtileHub systemd[1]: mhub.service: Failed with result ‘start-limit-hit’

where I am wrong? I do copy/paste of commands to minimize errors.
I copy via scp the whole openhab folder in /home/user and start over…

Thanks in advance for any help
G.


#28

Hi @Gabriele_Castiglioni,

Thanks for following the tutorial. I modified this tutorial on Friday (Nov 9) to highlight the codes in grey. Please note the spaces and dots. If you miss a space/dot or if it didn’t successfully copy all files during the process, it may result an error.

I will share a snapshots of how mine looks and you can compare them to yours

  1. Go to the /usr/share/mhub/ and check the files and ownernship of mhub (this was the openhab folder which you renamed to mhub)
    image

  2. Now go to the userdata folder

  3. Now go to the addons folder where you copied the openhab-addons file (step 2b) and the mixtile files (step 12b) (Not pictured, but you should also see the openhab-addons-2.3.0.kar file in your terminal)

  4. Finally go to mhub.service file and check if you copied it perfectly. (Step 17). Make sure you only have mhub.

Best,

Bac

Mixtile Team


#29

Thanks very much for the reply!
I checked them all and this is my situation…


Here i don’t see any difference. All mhub


here I cannot see any config nor cache folder (there wasn’t any in zipped openhab file) but root owner is correct


This is mhub.service (root owned)

addons folder is equal to your screen…

Any help is appreciated… thanks


#30

Hi @Gabriele_Castiglioni

Everything seems fine to me. The only thing I can think of is that you may have two of the same files in the same folder. You should have 1 mhub folder in /usr/share/ directory and 1 mhub.service file in /lib/systemd/system/ directory.And every time edit mhub.service, you need to do step 18 again. (systemctl daemon-reload…)

Best

Bac

Mixtile Team


#31

Checked all, and I have only 1 folder/file per type. No duplicate.
I had a try. Nice try. Thanks 4 all


#32

Hi @Gabriele_Castiglioni

Thanks for giving it a try. If you are still interested, you could try resetting your hub and starting over. It should be easier and faster the second time around.

We have another tutorial on how to port openhab2 bindings to eclipse smart home.

Best,

Bac

Mixtile


#33

Yes, I am.
At this time Mixtile hub is an expensive worthless device (Android app is … horrible and unusable).
I tried several time yesterday, by hard-resetting and build up from scratch. I even made a .sh fie with all commands copied/pasted , but always no luck.
I wish I can install HA but is not possible. OpenHAB can be a perfect substitute. SM Eclipse has a very limited PaperUI. i do not deal with it.

I will keep on trying this week. Then I’ll get a Rasp and store that unusable thing in the drawer waiting for MixTile crew to develop something usable.

Gabriele


#34

Hi @Gabriele_Castiglioni

I’m sorry our hub doesn’t meet your expectations. We actually updated our android app 2 days ago. This update made the hub/app more stable and solved the unpairing issue that many of you had. I’ve personally followed this tutorial and installed openhab to my hub half a dozens times. Other users have also succeeded as well. Would you be interested with a video tutorial?

Also may I ask what else you use our hub for?

Best,

Bac

Mixtile Team


#35

Full agreement with you. iOS app is very unstable, too. Installing openhab doesn’t make some positive changes because it doesn’t support native mobile app fully.
Seems that MH team haven’t even try to use apps with friendly interface with perfect functionality like “mi home” or “Elgato Eve”, for ex.
Everything they do - make uncomfortable (why not with script or inApp like changing permissions?) way to change useless ESH to Openhab without any further support.

By the way, MH team, information for you. I received your mainboard. See it. Is it permissible? I asked to check before sending!!

Sorry to another users for my writing in this public topic with my negativity.


#36

I have a lot of:

Nov 15 16:11:32 MixtileHub start_debug.sh[26777]: WARNING: The library file '/usr/share/ezdk-1.8.0_152/jre/lib/aarch32/libawt.so' is corrupted! Further execution might lead to unexpected behavior. Ensure that you have downloaded the build from http://zulu.org/download/
...

and

Nov 15 14:51:35 MixtileHub start.sh[21831]: shared memfd open() failed: Function not implemented
Nov 15 14:51:35 MixtileHub start.sh[21831]: shared memfd open() failed: Function not implemented
Nov 15 14:51:36 MixtileHub start.sh[21831]: shared memfd open() failed: Function not implemented
...

#37

Of course you can know about my usage.
I am a fan of Xiaomi/aqara product and I have a plenty of that. I use MiHome to set them up and use but I cannot configure them all under Google Home mini hardware, nor has an MQTT to command Sonoff hardware (Tasmota fw) neither Broadlink RM/SP/A1. This leads me to use a bunch of apps and deal with huge Chinese server lags. I do not chose Rasp before because of ZigBee operativity (i saw recently a usb pen to implement that on Rasp). This is why I jumped on MixTile boat. I was pretty sure to be able to command all my device with a dedicated server. But as far as I know i cannot do anything with it. How can this hub meet my expectation if it IS NOT CAPABLE of doing anything… I do not have tried updated app yet. Will do this evening.

@egoist I think they cannot do that script in app because of they will probabily lose users using SME. Hubs will be no more updated with new Fws and there will be no point on working on Android app. As for the user UI, They’d better focus on functionality before graphics. I’ll be the more happier with ugly UI and optimal controls. UI can be renewed by anyone. Scripts only by Mixtile team

@Bac I do not say your giude has fault. Simply i cannot do that on my hub. Can it be because of 1.7 fw installed? Can it be because of some regional hardware differences in hubs (I am in EU)

Thanks
Gabriele


#39

I think there won’t be new user after everyone see that this project not better than another’s.

For your needs I may recommend athom homey.

But as for me, there is nothing better than raspberry pi in a pair with original mi hub. I think you also could install mixtile hub binding on it😄


#40

Hi @Gabriele_Castiglioni

That’s good to know. We actually work with Xiaomi’s smart home supplier as well. Currently we are only developing a Sonoff switch for our hub. If Sonoff products are popular among our users, we’ll start developing them. The hub firmware and regional hardware difference shouldn’t be the problem. (btw our latest fw is 1.8). In the coming week, I’ll try to set it with a EU version to double check. It probably won’t help, but try deleting the openhab kar file from your add-ons folder in /usr/share/mhub. (The add-ons file is optional to set up openhab)

Also let me know if you have encountered any mistakes in this page


Hi @egoist

Thanks for your opinion. I don’t understand your photo and question. What is permissible and who asked you to check what Were you conversing with another Mixtile employee? If so, could you use the same email thread so we can get a better idea on how to help you.



#41

On photo there is the broken pigtail connector of mainboard that your college Fiona send me. I asked her to check workability of mainboard before sending. “Is it permissible?” means that it is very nonprofessional to send me broken part.
It means that your team the first time send me hub with non working zigbee, and the second time send me new mainboard with broken pigtail connector.